Original document with latest updates:
https://wiki.cnap.hv.se/practice/ccnp/labs/multicast-movie-challenge
This is how TV should work in the internet, but instead we all use TCP
https://en.wikipedia.org/wiki/Multicast_address
|--|--|
| Not routable | 224.0.0.0 - 224.0.0.255 "Local subnetwork" | Examples: RIPv2=224.0.0.9, EIGRP=224.0.0.10 |
| Routable | 239.0.0.0 to 239.255.255.255 Administratively scoped | The 239.0.0.0/8 range is assigned by RFC 2365 for private use within an organization. |
(config)# ip multicast-routing
(config)# ip pim rp-address 172.16.255.255
(config-if)# ip pim sparse-mode
3.3 Once (only on ONE router)
interface Loopback2
ip address 172.16.255.255 255.255.255.255
ip pim sparse-mode
ip ospf 1 area 0
Good Luck and Have Fun !!
VLC screendump 1
VLC screendump 2
:sout=#duplicate{
dst=std{access=udp{ttl=10},mux=ts,dst=239.7.7.7:1234},
dst=display}
Note the IP-address, port number and Protocol below
Command: show ip multicast interface
Please note below: Multicast packets in/out: 49351/16 that out increases.
2nd-try#show ip multicast ?
interface Multicast interface information
limit Multicast limit information
vrf Select VPN Routing/Forwarding instance
| Output modifiers
<cr>
2nd-try#show ip multicast interf
2nd-try#show ip multicast interface fa
2nd-try#show ip multicast interface fastEthernet 0/1
FastEthernet0/1 is up, line protocol is up
Internet address is 2.2.2.1/24
Multicast routing: enabled
Multicast switching: fast
Multicast packets in/out: 49351/16
Multicast TTL threshold: 0
Multicast Tagswitching: disabled
2nd-try#show ip multicast interface fastEthernet 0/1
FastEthernet0/1 is up, line protocol is up
Internet address is 2.2.2.1/24
Multicast routing: enabled
Multicast switching: fast
Multicast packets in/out: 49712/16
Multicast TTL threshold: 0
Multicast Tagswitching: disabled
2nd-try#show ip multicast interface fastEthernet 0/1
FastEthernet0/1 is up, line protocol is up
Internet address is 2.2.2.1/24
Multicast routing: enabled
Multicast switching: fast
Multicast packets in/out: 49920/16
Multicast TTL threshold: 0
Multicast Tagswitching: disabled
2nd-try#show ip igmp ?
groups IGMP group membership information
interface IGMP interface information
membership IGMP membership information for forwarding
snooping Snooping info on Catalyst Vlans
ssm-mapping Display IGMP SSM mapping info
udlr IGMP undirectional link multicast routing information
vrf Select VPN Routing/Forwarding instance
2nd-try#show ip igmp groups
IGMP Connected Group Membership
Group Address Interface Uptime Expires Last Reporter
239.255.255.250 FastEthernet0/0 00:53:57 00:02:20 1.1.1.11
239.255.255.250 FastEthernet0/1 00:54:01 00:02:11 2.2.2.10
239.3.3.3 FastEthernet0/1 00:49:56 00:02:15 2.2.2.1
239.3.3.3 FastEthernet0/0 00:52:26 00:02:14 1.1.1.1
239.7.7.7 FastEthernet0/1 00:20:27 00:02:14 2.2.2.10
239.7.7.7 FastEthernet0/0 00:20:45 00:02:11 1.1.1.11
224.0.1.40 FastEthernet0/1 00:54:03 00:02:19 2.2.2.1
2nd-try#show ip igmp membership
Flags: A - aggregate, T - tracked
L - Local, S - static, V - virtual, R - Reported through v3
I - v3lite, U - Urd, M - SSM (S,G) channel
1,2,3 - The version of IGMP the group is in
Channel/Group-Flags:
/ - Filtering entry (Exclude mode (S,G), Include mode (*,G))
Reporter:
<mac-or-ip-address> - last reporter if group is not explicitly tracked
<n>/<m> - <n> reporter in include mode, <m> reporter in exclude
Channel/Group Reporter Uptime Exp. Flags Interface
*,239.255.255.250 1.1.1.11 00:54:04 02:13 2A Fa0/0
*,239.255.255.250 2.2.2.10 00:54:09 02:04 2A Fa0/1
*,239.3.3.3 2.2.2.1 00:50:03 02:08 2LA Fa0/1
*,239.3.3.3 1.1.1.1 00:52:33 02:07 2LA Fa0/0
*,239.7.7.7 2.2.2.10 00:20:34 02:07 2A Fa0/1
*,239.7.7.7 1.1.1.11 00:20:52 02:04 2A Fa0/0
*,224.0.1.40 2.2.2.1 00:54:10 02:12 2LA Fa0/1
2nd-try#show ip pim ?
autorp Global AutoRP information
boundary debug boundary comand
bsr-router Bootstrap router (v2)
interface PIM interface information
mdt Multicast tunnel information
neighbor PIM neighbor information
rp PIM Rendezvous Point (RP) information
rp-hash RP to be chosen based on group selected
vrf Select VPN Routing/Forwarding instance
2nd-try#show ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
S - State Refresh Capable
Neighbor Interface Uptime/Expires Ver DR
Address Prio/Mode
2nd-try#show ip mroute
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
L - Local, P - Pruned, R - RP-bit set, F - Register flag,
T - SPT-bit set, J - Join SPT, M - MSDP created entry,
X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
U - URD, I - Received Source Specific Host Report,
Z - Multicast Tunnel, z - MDT-data group sender,
Y - Joined MDT-data group, y - Sending to MDT-data group
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode
(*, 239.255.255.250), 00:54:55/00:02:19, RP 0.0.0.0, flags: DC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:54:50/00:00:00
FastEthernet0/1, Forward/Sparse-Dense, 00:54:55/00:00:00
(*, 239.3.3.3), 00:53:19/00:02:22, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/1, Forward/Sparse-Dense, 00:50:49/00:00:00
FastEthernet0/0, Forward/Sparse-Dense, 00:53:19/00:00:00
(*, 239.7.7.7), 00:21:38/stopped, RP 0.0.0.0, flags: DC
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/1, Forward/Sparse-Dense, 00:21:20/00:00:00
FastEthernet0/0, Forward/Sparse-Dense, 00:21:38/00:00:00
(2.2.2.10, 239.7.7.7), 00:11:46/00:02:55, flags: T
Incoming interface: FastEthernet0/1, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/0, Forward/Sparse-Dense, 00:11:46/00:00:00
(*, 224.0.1.40), 00:54:59/00:02:22, RP 0.0.0.0, flags: DCL
Incoming interface: Null, RPF nbr 0.0.0.0
Outgoing interface list:
FastEthernet0/1, Forward/Sparse-Dense, 00:54:59/00:00:00
2nd-try#show running
Building configuration...
Current configuration : 1024 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname 2nd-try
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
resource policy
!
ip cef
!
no ip domain lookup
ip multicast-routing
!
voice-card 0
!
interface FastEthernet0/0
ip address 1.1.1.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 239.3.3.3
duplex auto
speed auto
!
interface FastEthernet0/1
ip address 2.2.2.1 255.255.255.0
ip pim sparse-dense-mode
ip igmp join-group 239.3.3.3
duplex auto
speed auto
!
interface Serial0/1/0
no ip address
shutdown
no fair-queue
clock rate 2000000
!
interface Serial0/1/1
no ip address
shutdown
clock rate 2000000
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
webvpn context Default_context
ssl authenticate verify all
!
no inservice
!
end
2nd-try#debug ip igmp 239.7.7.7
IGMP debugging is on
2nd-try#
*Oct 7 07:33:00.851: IGMP(0): Send v2 general Query on FastEthernet0/1
*Oct 7 07:33:00.851: IGMP(0): Set report delay time to 2.8 seconds for 239.7.7.7 on FastEthernet0/1
*Oct 7 07:33:01.851: IGMP(0): Send v2 general Query on FastEthernet0/0
*Oct 7 07:33:01.851: IGMP(0): Set report delay time to 5.2 seconds for 239.7.7.7 on FastEthernet0/0
*Oct 7 07:33:02.119: IGMP(0): Received v2 Report on FastEthernet0/0 from 1.1.1.11 for 239.7.7.7
*Oct 7 07:33:02.119: IGMP(0): Received Group record for group 239.7.7.7, mode 2 from 1.1.1.11 for 0 sources
*Oct 7 07:33:02.119: IGMP(0): Cancel report for 239.7.7.7 on FastEthernet0/0
*Oct 7 07:33:02.119: IGMP(0): Updating EXCLUDE group timer for 239.7.7.7
*Oct 7 07:33:02.119: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,239.7.7.7) by 0
*Oct 7 07:33:03.343: IGMP(0): Received v2 Report on FastEthernet0/1 from 2.2.2.10 for 239.7.7.7
*Oct 7 07:33:03.343: IGMP(0): Received Group record for group 239.7.7.7, mode 2 from 2.2.2.10 for 0 sources
*Oct 7 07:33:03.343: IGMP(0): Cancel report for 239.7.7.7 on FastEthernet0/1
*Oct 7 07:33:03.343: IGMP(0): Updating EXCLUDE group timer for 239.7.7.7
*Oct 7 07:33:03.343: IGMP(0): MRT Add/Update FastEthernet0/1 for (*,239.7.7.7) by 0
*Oct 7 07:33:09.843: IGMP(0): Report has illegal group address 224.0.0.252
*Oct 7 07:33:11.119: IGMP(0): Report has illegal group address 224.0.0.252
*Oct 7 07:33:35.555: IGMP(0): Received Leave from 1.1.1.11 (FastEthernet0/0) for 239.7.7.7
*Oct 7 07:33:35.555: IGMP(0): Received Group record for group 239.7.7.7, mode 3 from 1.1.1.11 for 0 sources
*Oct 7 07:33:35.555: IGMP(0): Lower expiration timer to 2000 msec for 239.7.7.7 on FastEthernet0/0
*Oct 7 07:33:35.555: IGMP(0): Send v2 Query on FastEthernet0/0 for group 239.7.7.7
*Oct 7 07:33:35.555: IGMP(0): Set report delay time to 0.6 seconds for 239.7.7.7 on FastEthernet0/0
*Oct 7 07:33:35.635: IGMP(0): Received v2 Report on FastEthernet0/0 from 1.1.1.11 for 239.7.7.7
*Oct 7 07:33:35.635: IGMP(0): Received Group record for group 239.7.7.7, mode 2 from 1.1.1.11 for 0 sources
*Oct 7 07:33:35.635: IGMP(0): Cancel report for 239.7.7.7 on FastEthernet0/0
*Oct 7 07:33:35.635: IGMP(0): Updating EXCLUDE group timer for 239.7.7.7
*Oct 7 07:33:35.635: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,239.7.7.7) by 0
*Oct 7 07:33:36.123: IGMP(0): Received v2 Report on FastEthernet0/0 from 1.1.1.11 for 239.7.7.7
*Oct 7 07:33:36.123: IGMP(0): Received Group record for group 239.7.7.7, mode 2 from 1.1.1.11 for 0 sources
*Oct 7 07:33:36.123: IGMP(0): Updating EXCLUDE group timer for 239.7.7.7
*Oct 7 07:33:36.123: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,239.7.7.7) by 0
*Oct 7 07:34:01.555: IGMP(0): Send v2 general Query on FastEthernet0/1
-------------- SNIP SNIP ---------------
2nd-try#
*Oct 7 07:38:01.555: IGMP(0): Send v2 general Query on FastEthernet0/1
*Oct 7 07:38:01.555: IGMP(0): Set report delay time to 7.6 seconds for 239.7.7.7 on FastEthernet0/1
*Oct 7 07:38:02.555: IGMP(0): Send v2 general Query on FastEthernet0/0
*Oct 7 07:38:02.555: IGMP(0): Set report delay time to 2.8 seconds for 239.7.7.7 on FastEthernet0/0
*Oct 7 07:38:03.651: IGMP(0): Report has illegal group address 224.0.0.252
*Oct 7 07:38:04.151: IGMP(0): Received v2 Report on FastEthernet0/0 from 1.1.1.11 for 239.7.7.7
*Oct 7 07:38:04.151: IGMP(0): Received Group record for group 239.7.7.7, mode 2 from 1.1.1.11 for 0 sources
*Oct 7 07:38:04.151: IGMP(0): Cancel report for 239.7.7.7 on FastEthernet0/0
*Oct 7 07:38:04.151: IGMP(0): Updating EXCLUDE group timer for 239.7.7.7
*Oct 7 07:38:04.151: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,239.7.7.7) by 0
*Oct 7 07:38:05.883: IGMP(0): Received v2 Report on FastEthernet0/1 from 2.2.2.10 for 239.7.7.7
*Oct 7 07:38:05.883: IGMP(0): Received Group record for group 239.7.7.7, mode 2 from 2.2.2.10 for 0 sources
*Oct 7 07:38:05.883: IGMP(0): Cancel report for 239.7.7.7 on FastEthernet0/1
*Oct 7 07:38:05.883: IGMP(0): Updating EXCLUDE group timer for 239.7.7.7
*Oct 7 07:38:05.883: IGMP(0): MRT Add/Update FastEthernet0/1 for (*,239.7.7.7) by 0
*Oct 7 07:38:06.383: IGMP(0): Report has illegal group address 224.0.0.252
*Oct 7 07:39:01.555: IGMP(0): Send v2 general Query on FastEthernet0/1
*Oct 7 07:39:01.555: IGMP(0): Set report delay time to 4.8 seconds for 239.7.7.7 on FastEthernet0/1
*Oct 7 07:39:02.555: IGMP(0): Send v2 general Query on FastEthernet0/0
*Oct 7 07:39:02.555: IGMP(0): Set report delay time to 1.2 seconds for 239.7.7.7 on FastEthernet0/0
*Oct 7 07:39:03.391: IGMP(0): Report has illegal group address 224.0.0.252
*Oct 7 07:39:04.555: IGMP(0): Send v2 Report for 239.7.7.7 on FastEthernet0/0
*Oct 7 07:39:04.555: IGMP(0): Received v2 Report on FastEthernet0/0 from 1.1.1.1 for 239.7.7.7
*Oct 7 07:39:04.555: IGMP(0): Received Group record for group 239.7.7.7, mode 2 from 1.1.1.1 for 0 sources
*Oct 7 07:39:04.555: IGMP(0): Updating EXCLUDE group timer for 239.7.7.7
*Oct 7 07:39:04.555: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,239.7.7.7) by 0
*Oct 7 07:39:06.555: IGMP(0): Send v2 Report for 239.7.7.7 on FastEthernet0/1
*Oct 7 07:39:06.555: IGMP(0): Received v2 Report on FastEthernet0/1 from 2.2.2.1 for 239.7.7.7
*Oct 7 07:39:06.555: IGMP(0): Received Group record for group 239.7.7.7, mode 2 from 2.2.2.1 for 0 sources
*Oct 7 07:39:06.555: IGMP(0): Updating EXCLUDE group timer for 239.7.7.7
*Oct 7 07:39:06.555: IGMP(0): MRT Add/Update FastEthernet0/1 for (*,239.7.7.7) by 0
*Oct 7 07:39:09.159: IGMP(0): Report has illegal group address 224.0.0.252
2nd-try#
2nd-try#startar 1.1.1.10
^
% Invalid input detected at '^' marker.
2nd-try#
*Oct 7 07:40:01.555: IGMP(0): Send v2 general Query on FastEthernet0/1
*Oct 7 07:40:01.555: IGMP(0): Set report delay time to 9.6 seconds for 239.7.7.7 on FastEthernet0/1
*Oct 7 07:40:02.555: IGMP(0): Send v2 general Query on FastEthernet0/0
*Oct 7 07:40:02.555: IGMP(0): Set report delay time to 2.0 seconds for 239.7.7.7 on FastEthernet0/0
*Oct 7 07:40:03.899: IGMP(0): Received v2 Report on FastEthernet0/1 from 2.2.2.10 for 239.7.7.7
*Oct 7 07:40:03.899: IGMP(0): Received Group record for group 239.7.7.7, mode 2 from 2.2.2.10 for 0 sources
*Oct 7 07:40:03.899: IGMP(0): Cancel report for 239.7.7.7 on FastEthernet0/1
*Oct 7 07:40:03.899: IGMP(0): Updating EXCLUDE group timer for 239.7.7.7
*Oct 7 07:40:03.899: IGMP(0): MRT Add/Update FastEthernet0/1 for (*,239.7.7.7) by 0
*Oct 7 07:40:04.167: IGMP(0): Received v2 Report on FastEthernet0/0 from 1.1.1.11 for 239.7.7.7
*Oct 7 07:40:04.167: IGMP(0): Received Group record for group 239.7.7.7, mode 2 from 1.1.1.11 for 0 sources
*Oct 7 07:40:04.167: IGMP(0): Cancel report for 239.7.7.7 on FastEthernet0/0
*Oct 7 07:40:04.167: IGMP(0): Updating EXCLUDE group timer for 239.7.7.7
*Oct 7 07:40:04.167: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,239.7.7.7) by 0
*Oct 7 07:40:04.667: IGMP(0): Report has illegal group address 224.0.0.252
*Oct 7 07:40:08.899: IGMP(0): Report has illegal group address 224.0.0.252
2nd-try#ffwd stop
^
% Invalid input detected at '^' marker.
2nd-try#
*Oct 7 07:41:01.555: IGMP(0): Send v2 general Query on FastEthernet0/1
*Oct 7 07:41:01.555: IGMP(0): Set report delay time to 1.2 seconds for 239.7.7.7 on FastEthernet0/1
*Oct 7 07:41:02.555: IGMP(0): Send v2 general Query on FastEthernet0/0
*Oct 7 07:41:02.555: IGMP(0): Set report delay time to 9.2 seconds for 239.7.7.7 on FastEthernet0/0
*Oct 7 07:41:03.171: IGMP(0): Report has illegal group address 224.0.0.252
*Oct 7 07:41:03.555: IGMP(0): Send v2 Report for 239.7.7.7 on FastEthernet0/1
*Oct 7 07:41:03.555: IGMP(0): Received v2 Report on FastEthernet0/1 from 2.2.2.1 for 239.7.7.7
*Oct 7 07:41:03.555: IGMP(0): Received Group record for group 239.7.7.7, mode 2 from 2.2.2.1 for 0 sources
*Oct 7 07:41:03.555: IGMP(0): Updating EXCLUDE group timer for 239.7.7.7
*Oct 7 07:41:03.555: IGMP(0): MRT Add/Update FastEthernet0/1 for (*,239.7.7.7) by 0
*Oct 7 07:41:04.171: IGMP(0): Received v2 Report on FastEthernet0/0 from 1.1.1.11 for 239.7.7.7
*Oct 7 07:41:04.171: IGMP(0): Received Group record for group 239.7.7.7, mode 2 from 1.1.1.11 for 0 sources
*Oct 7 07:41:04.171: IGMP(0): Cancel report for 239.7.7.7 on FastEthernet0/0
*Oct 7 07:41:04.171: IGMP(0): Updating EXCLUDE group timer for 239.7.7.7
*Oct 7 07:41:04.171: IGMP(0): MRT Add/Update FastEthernet0/0 for (*,239.7.7.7) by 0
*Oct 7 07:41:06.907: IGMP(0): Report has illegal group address 224.0.0.252
2nd-try#
2nd-try#
text