Here I tell the sad and tragic story of my life with UEFI PXE boot
1. If I choose the wrong installation ISO, it will not work
Rufus must burn an uefi installation, and
this option is only present when the ISO is UEFI-windows
2. If I send the wrong DHCP options, it will not work
Do not use option 150 (cisco propretary) or Vendor-code (which is wrong)
Useoption 66 ip 10.0.0.1
and
option 67 ascii syslinux.efi
3. If I use an old tftp server, it will not work
Oct 26 21:11:30.992: TFTP: Opened flash0:syslinux.efi, fd 10, size 193230 for process 33
Oct 26 21:11:30.992: TFTP: Sending block 1 (retry 0), len 512, socket_id 0x218D5EA4
Oct 26 21:11:30.992: TFTP: error code 4 received - 21875
Oct 26 21:11:30.992: TFTP: Finished flash0:syslinux.efi, time 00:00:00 for process 33
4. If I use the the wrong PXE-image, it will not work
PC will crash and hang
5. Life continues...
I Choose iPXE (formerly gPXE) becouse it is used by FOG
GPT
and UEFI (non CSM)
; otherwise you have downloaded the wrong .ISO
3. After installing (next next next) you should have
![efi-partition.png](/efi-partition.png)
and
![partitionstylegpt.png](/images/partitionstylegpt.png)
interface vlan 1
interface gi 0/0/0
ip address 10.0.0.1 255.255.255.0
no shut
ip dhcp pool v4-pool
network 10.0.0.0 255.255.255.0
default-router 10.0.0.1
option 66 ip 10.0.0.1
option 67 ascii syslinux.efi
lease infinite
PXE-Robert#show running | incl tftp
tftp-server flash0:/home.shtml alias home.shtml
tftp-server flash0:ipxe.efi alias ipxe.efi
tftp-server flash0:syslinux.efi alias syslinux.efi
tftp-server flash0:pxelinux.gpxe alias pxelinux.gpxe
PXE-Robert#dir
Directory of flash0:/
12 -rw- 1016320 Oct 26 2022 20:53:14 +00:00 ipxe.efi
13 -rw- 193230 Oct 26 2022 20:53:30 +00:00 syslinux.efi
14 -rw- 74 Oct 26 2022 21:03:40 +00:00 pxelinux.gpxe
260157440 bytes total (143060992 bytes free)
*Oct 26 21:11:30.992: TFTP: Opened flash0:syslinux.efi, fd 10, size 193230 for process 33
*Oct 26 21:11:30.992: TFTP: Sending block 1 (retry 0), len 512, socket_id 0x218D5EA4
*Oct 26 21:11:30.992: TFTP: error code 4 received - 21875
*Oct 26 21:11:30.992: TFTP: Finished flash0:syslinux.efi, time 00:00:00 for process 33
cisco.com: tftp-error-codes
0 Not defined, see error message (if any).
1 File not found.
2 Access violation.
3 Disk full or allocation exceeded.
4 Illegal TFTP operation.
5 Unknown transfer ID.
6 File already exists.
7 No such user.
Using BIOS, the file transfer works; but the PC crashes instead !?!
Discarded https://en.wikipedia.org/wiki/SYSLINUX even though it has nice graphix
You can use HTTP boot (not tftp) so only a web-server is needed
https://ipxe.org/appnote/uefihttp
DOWNLOAD ipxe.efi-file from above URL and " iPXE binary (e.g. ipxe.efi) "
SYSLINUX Boot Screen
https://github.com/ipxe/ipxe/issues/517
https://forums.fogproject.org/topic/12132/pxe-boot-fog-menu
for bios mode you can use ipxe.pxe or undionly.kpxe
for uefi mode you can use ipxe.efi or snponly.efi
What you do have configured for dhcp options 66 and 67. Also be sure you don’t have dhcp option 60 set.
ipv6 dhcp pool https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/ipv6/command/ipv6-cr-book/ipv6-i1.html
https://grumpy-networkers-journal.readthedocs.io/en/latest/STUDY_NOTES/CISCO_SWITCH/DHCP.html
https://docs.oracle.com/cd/E37670_01/E41137/html/ol-pxe-boot.html
subnet 10.0.0.0 netmask 255.255.255.0 {
option domain-name-servers 10.0.0.1;
option broadcast-address 10.0.0.255;
option routers 10.0.0.1;
default-lease-time 14400;
max-lease-time 28800;
if substring(vendorclass, 0, 9)="PXEClient" {
if pxetype=00:06 or pxetype=00:07 {
filename "efi/BOOTX64.efi";
} else {
filename "pxelinux/pxelinux.0";
}
}
pool {
range 10.0.0.101 10.0.0.200;
}
next-server 10.0.0.6;
}
https://docs.oracle.com/cd/E37670_01/E41137/html/ol-pxe-boot.html
https://grumpy-networkers-journal.readthedocs.io/en/latest/STUDY_NOTES/CISCO_SWITCH/DHCP.html --- System Configuration Dialog ---
cnap-brouter3650#conf t cisco Enter configuration commands, one per line. End with CNTL/Z.
cnap-brouter3650(config)#ipv6 dhcp pool test-kill-me
cnap-brouter3650(config-dhcpv6)#?
IPv6 DHCP configuration commands:
address IPv6 address allocation
default Set a command to its defaults
dns-server DNS servers
domain-name Domain name to complete unqualified host names
exit Exit from DHCPv6 configuration mode
import Import options
information Information refresh option
link-address Link-address to match
nis NIS server options
nisp NISP server options
no Negate a command or set its defaults
prefix-delegation IPv6 prefix delegation
sip SIP server options
sntp SNTP server options
vendor-specific Configure Vendor-specific option
cnap-brouter3650(config-dhcpv6)#vendor-specific ?
1-4294967295> Enterprise ID
cnap-brouter3650(config-dhcpv6)#vendor-specific 60
cnap-brouter3650(config-dhcpv6-vs)#?
IPv6 DHCP Vendor-specific option configuration commands:
default Set a command to its defaults
exit Exit from DHCPv6 vendor-specific option configuration mode
no Negate a command or set its defaults
suboption Vendor-specific suboption
cnap-brouter3650(config-dhcpv6-vs)#suboption ?
1-65535> Suboption number
cnap-brouter3650(config-dhcpv6-vs)#suboption 1 ?
address IPv6 address
ascii ASCII string
hex Hex value
cnap-brouter3650(config-dhcpv6-vs)#suboption 1 ascii robert.txt
https://grumpy-networkers-journal.readthedocs.io/en/latest/STUDY_NOTES/CISCO_SWITCH/DHCP.html
https://docs.oracle.com/cd/E37670_01/E41137/html/ol-pxe-boot.html
subnet 10.0.0.0 netmask 255.255.255.0 {
option domain-name-servers 10.0.0.1;
option broadcast-address 10.0.0.255;
option routers 10.0.0.1;
default-lease-time 14400;
max-lease-time 28800;
if substring(vendorclass, 0, 9)="PXEClient" {
if pxetype=00:06 or pxetype=00:07 {
filename "efi/BOOTX64.efi";
} else {
filename "pxelinux/pxelinux.0";
}
}
pool {
range 10.0.0.101 10.0.0.200;
}
next-server 10.0.0.6;
}
https://docs.oracle.com/cd/E37670_01/E41137/html/ol-pxe-boot.html
https://grumpy-networkers-journal.readthedocs.io/en/latest/STUDY_NOTES/CISCO_SWITCH/DHCP.html --- System Configuration Dialog ---
Would you like to enter the initial configuration dialog? \[yes/no\]:
% Please answer 'yes' or 'no'.
Would you like to enter the initial configuration dialog? \[yes/no\]:
% Please answer 'yes' or 'no'.
Would you like to enter the initial configuration dialog? \[yes/no\]:
% Please answer 'yes' or 'no'.
Would you like to enter the initial configuration dialog? \[yes/no\]:
% Please answer 'yes' or 'no'.
Would you like to enter the initial configuration dialog? \[yes/no\]:
% Please answer 'yes' or 'no'.
Would you like to enter the initial configuration dialog? \[yes/no\]:
% Please answer 'yes' or 'no'.
Would you like to enter the initial configuration dialog? \[yes/no\]: nmo
% Please answer 'yes' or 'no'.
Would you like to enter the initial configuration dialog? \[yes/no\]: no
Press RETURN to get started!
\*Jan 2 00:00:03.191: %SMART\_LIC-6-AGENT\_READY: Smart Agent for Licensing is ini tialized
\*Jan 2 00:00:03.467: %IOS\_LICENSE\_IMAGE\_APPLICATION-6-LICENSE\_LEVEL: Module nam e = c2900 Next reboot level = ipbasek9 and License = ipbasek9
\*Jan 2 00:00:03.615: %IOS\_LICENSE\_IMAGE\_APPLICATION-6-LICENSE\_LEVEL: Module nam e = c2900 Next reboot level = securityk9 and License = securityk9
\*Jan 2 00:00:03.779: %IOS\_LICENSE\_IMAGE\_APPLICATION-6-LICENSE\_LEVEL: Module nam e = c2900 Next reboot level = datak9 and License
Router>= datak9
\*Oct 14 15:34:22.251: c3600\_scp\_set\_dstaddr2\_idb(185)add = 80 name is Embedded-S ervice-Engine0/0
\*Oct 14 15:34:36.023: %VPN\_HW-6-INFO\_LOC: Crypto engine: onboard 0 State change d to: Initialized
\*Oct 14 15:34:36.027: %VPN\_HW-6-INFO\_LOC: Crypto engine: onboard 0 State change d to: Enabled
\*Oct 14 15:34:41.319: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed stat e to up
\*Oct 14 15:34:41.319: %LINK-3-UPDOWN: Interface GigabitEthernet0/1, changed stat e to down
\*Oct 14 15:34:41.319: %LINK-3-UPDOWN: Interface GigabitEthernet0/2, changed stat e to down
\*Oct 14 15:34:42.431: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEth ernet0/0, changed state to up
\*Oct 14 15:34:42.431: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEth ernet0/1, changed state to down
\*Oct 14 15:34:42.431: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEth ernet0/2, changed state to down
\*Oct 14 15:35:33.695: %IP-5-WEBINST\_KILL: Terminating DNS process
\*Oct 14 15:35:33.735: %LINK-5-CHANGED: Interface Embedded-Service-Engine0/0, cha nged state to administratively down
\*Oct 14 15:35:33.735: %LINK-5-CHANGED: Interface GigabitEthernet0/0, changed sta te to administratively down
\*Oct 14 15:35:33.739: %LINK-5-CHANGED: Interface GigabitEthernet0/1, changed sta te to administratively down
\*Oct 14 15:35:33.739: %LINK-5-CHANGED: Interface GigabitEthernet0/2, changed sta te to administratively down
\*Oct 14 15:35:34.735: %LINEPROTO-5-UPDOWN: Line protocol on Interface Embedded-S ervice-Engine0/0, changed state to down
\*Oct 14 15:35:34.735: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEth ernet0/0, changed state to down
\*Oct 14 15:35:43.143: %SYS-5-RESTART: System restarted --
Cisco IOS Software, C2900 Software (C2900-UNIVERSALK9-M), Version 15.7(3)M3, REL EASE SOFTWARE (fc2)
Technical Support: [http://www.cisco.com/techsupport](http://www.cisco.com/techsupport)
Copyright (c) 1986-2018 by Cisco Systems, Inc.
Compiled Wed 01-Aug-18 21:47 by prod\_rel\_team
\*Oct 14 15:35:43.815: %SYS-6-BOOTTIME: Time taken to reboot after reload = 14106 534 seconds
\*Oct 14 15:35:44.427: %CRYPTO-6-ISAKMP\_ON\_OFF: ISAKMP is OFF
\*Oct 14 15:35:44.427: %CRYPTO-6-GDOI\_ON\_OFF: GDOI is OFF
\*Oct 14 15:35:44.427: %CRYPTO-6-ISAKMP\_ON\_OFF: ISAKMP is OFF
\*Oct 14 15:35:44.427: %CRYPTO-6-GDOI\_ON\_OFF: GDOI is OFF
\*Oct 14 15:36:05.483: %PNP-6-PNP\_DISCOVERY\_STOPPED: PnP Discovery stopped (Confi g Wizard)
Router>
Router>ena
Router#conf t
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname PXE-Robert
PXE-Robert(config)#
PXE-Robert(config)#interf gi 0/1
PXE-Robert(config-if)#ip address
PXE-Robert(config-if)#ip address dh
PXE-Robert(config-if)#ip address dhcp
PXE-Robert(config-if)#interf go 0/0
^
% Invalid input detected at '^' marker.
PXE-Robert(config)#interf gi 0/0
PXE-Robert(config-if)#ipv6 address 2001::1?
WORD X:X:X:X::X X:X:X:X::X/ 0-128>
PXE-Robert(config-if)#ipv6 address 2001::1/64
PXE-Robert(config-if)#no shut
PXE-Robert(config-if)#exit
PXE-Robert(config)#
\*Oct 14 15:40:33.963: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed stat e to down
\*Oct 14 15:40:39.427: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed stat e to up
\*Oct 14 15:40:40.427: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEth ernet0/0, changed state to up
PXE-Robert(config)#
PXE-Robert(config)#ipv6 dhcp pool pxe-pool
PXE-Robert(config-dhcpv6)#address prefix 2001::/64
PXE-Robert(config-dhcpv6)#domain-name [cnap.hv.se](http://cnap.hv.se)
PXE-Robert(config-dhcpv6)#exit
PXE-Robert(config)#interf gi 0/0
PXE-Robert(config-if)#ipv6 dhcp server pxe-pool
PXE-Robert(config-if)#ipv6 nd ?
advertisement-interval Send an advertisement interval option in RA's
autoconfig Automatic Configuration
cache Cache entry
dad Duplicate Address Detection
destination-guard Query destination-guard switch table
managed-config-flag Hosts should use DHCP for address config
na Neighbor Advertisement control
ns-interval Set advertised NS retransmission interval
nud Neighbor Unreachability Detection
other-config-flag Hosts should use DHCP for non-address config
prefix Configure IPv6 Routing Prefix Advertisement
ra Router Advertisement control
reachable-time Set advertised reachability time
router-preference Set default router preference value
secured Configure SEND
PXE-Robert(config-if)#ipv6 nd ot
PXE-Robert(config-if)#ipv6 nd other-config-flag
PXE-Robert(config-if)#ipv6 nd ra
PXE-Robert(config-if)#ipv6 nd ra ?
dns DNS
hop-limit IPv6 RA hop-limit value
interval Set IPv6 Router Advertisement Interval
lifetime Set IPv6 Router Advertisement Lifetime
mtu IPv6 RA MTU Option
solicited Set solicited Router Advertisement response method
suppress Suppress IPv6 Router Advertisements
PXE-Robert(config-if)#
PXE-Robert(config-if)#exit
PXE-Robert(config)#exit
PXE-Robert#wr
Building configuration...
\*Oct 14 15:43:17.015: %SYS-5-CONFIG\_I: Configured from console by console\[OK\]
PXE-Robert#conf t
Enter configuration commands, one per line. End with CNTL/Z.
PXE-Robert(config)#ipv6 dhcp pool pxe-pool
PXE-Robert(config-dhcpv6)#?
IPv6 DHCP configuration commands:
address IPv6 address allocation
default Set a command to its defaults
dns-server DNS servers
domain-name Domain name to complete unqualified host names
exit Exit from DHCPv6 configuration mode
import Import options
information Information refresh option
link-address Link-address to match
nis NIS server options
nisp NISP server options
no Negate a command or set its defaults
option DHCPv6 Options configuration
prefix-delegation IPv6 prefix delegation
sip SIP server options
sntp SNTP server options
vendor-specific Configure Vendor-specific option
vrf Associate pool with a VRF
PXE-Robert(config-dhcpv6)#ve
PXE-Robert(config-dhcpv6)#vendor-specific ?
1-4294967295> Enterprise ID
PXE-Robert(config-dhcpv6)#vendor-specific 66 ?
cr>
PXE-Robert(config-dhcpv6)#vendor-specific 66
PXE-Robert(config-dhcpv6-vs)#?
IPv6 DHCP Vendor-specific option configuration commands:
default Set a command to its defaults
exit Exit from DHCPv6 vendor-specific option configuration mode
no Negate a command or set its defaults
suboption Vendor-specific suboption
PXE-Robert(config-dhcpv6-vs)#su
PXE-Robert(config-dhcpv6-vs)#suboption ?
1-65535> Suboption number
PXE-Robert(config-dhcpv6-vs)#suboption 1 ?
address IPv6 address
ascii ASCII string
hex Hex value
PXE-Robert(config-dhcpv6-vs)#suboption 1 address ?
X:X:X:X::X IPv6 address
PXE-Robert(config-dhcpv6-vs)#suboption 1 address 2001::1 ?
X:X:X:X::X IPv6 address
cr>
PXE-Robert(config-dhcpv6-vs)#suboption 1 address 2001::1
PXE-Robert(config-dhcpv6-vs)#exit
PXE-Robert(config-dhcpv6)#vendor-specific 67
PXE-Robert(config-dhcpv6-vs)#suboption 1 ?
address IPv6 address
ascii ASCII string
hex Hex value
PXE-Robert(config-dhcpv6-vs)#suboption 1 ascii ipxe.efi
PXE-Robert(config-dhcpv6-vs)#^Z
PXE-Robert#
PXE-Robert#wr
Building configuration...
\*Oct 14 15:47:10.543: %SYS-5-CONFIG\_I: Configured from console by console\[OK\]
PXE-Robert#
PXE-Robert#debug ipv6 dh
PXE-Robert#debug ipv6 dhcp ?
database IPv6 DHCP database debugging
detail IPv6 DHCP packet content
relay IPv6 DHCP relay debugging
cr>
PXE-Robert#debug ipv6 dhcp deta
PXE-Robert#debug ipv6 dhcp detail
IPv6 DHCP debugging is on (detailed)
PXE-Robert#
\*Oct 14 15:47:37.331: IPv6 DHCP: Received SOLICIT from FE80::3617:EBFF:FEDF:15B5 on GigabitEthernet0/0
\*Oct 14 15:47:37.331: IPv6 DHCP: detailed packet contents
\*Oct 14 15:47:37.331: src FE80::3617:EBFF:FEDF:15B5 (GigabitEthernet0/0)
\*Oct 14 15:47:37.331: dst FF02::1:2
\*Oct 14 15:47:37.331: type SOLICIT(1), xid 6547418
\*Oct 14 15:47:37.331: option CLIENTID(1), len 18
\*Oct 14 15:47:37.331: 000400020003000400050006000700080009
\*Oct 14 15:47:37.331: option ELAPSED-TIME(8), len 2
\*Oct 14 15:47:37.331: elapsed-time 0
\*Oct 14 15:47:37.331: option IA-NA(3), len 12
\*Oct 14 15:47:37.331: IAID 0xDFFBF777, T1 4294967295, T2 4294967295
\*Oct 14 15:47:37.331: option ORO(6), len 4
\*Oct 14 15:47:37.331: UNKNOWN,UNKNOWN
\*Oct 14 15:47:37.331: option UNKNOWN(62), len 3
\*Oct 14 15:47:37.331: option UNKNOWN(61), len 2
\*Oct 14 15:47:37.331: option VENDOR-CLASS(16), len 38
\*Oct 14 15:47:37.331: IPv6 DHCP: Option UNKNOWN(62) is not processed
\*Oct 14 15:47:37.331: IPv6 DHCP: Option UNKNOWN(61) is not processed
\*Oct 14 15:47:37.331: IPv6 DHCP: Option VENDOR-CLASS(16) is not processed
\*Oct 14 15:47:37.331: IPv6 DHCP: Using interface pool pxe-pool
\*Oct 14 15:47:37.331: IPv6 DHCP: Creating binding for FE80::3617:EBFF:FEDF:15B5 in pool pxe-pool
\*Oct 14 15:47:37.331: IPv6 DHCP: Binding for IA\_NA DFFBF777 not found
\*Oct 14 15:47:37.331: IPv6 DHCP: Allocating IA\_NA DFFBF777 in binding for FE80:: 3617:EBFF:FEDF:15B5
\*Oct 14 15:47:37.331: IPv6 DHCP: Looking up pool 2001::/64 entry with username ' 000400020003000400050006000700080009DFFBF777'
\*Oct 14 15:47:37.331: IPv6 DHCP: Poolentry for user not found
\*Oct 14 15:47:37.331: IPv6 DHCP: Allocated new address 2001::8C92:627D:C82D:8FB3
\*Oct 14 15:47:37.331: IPv6 DHCP: Allocating address 2001::8C92:627D:C82D:8FB3 in binding for FE80::3617:EBFF:FEDF:15B5, IAID DFFBF777
\*Oct 14 15:47:37.331: IPv6 DHCP: Updating binding address entry for address 2001 ::8C92:627D:C82D:8FB3
\*Oct 14 15:47:37.331: IPv6 DHCP: Setting timer on 2001::8C92:627D:C82D:8FB3 for 60 seconds
\*Oct 14 15:47:37.331: IPv6 DHCP: SAS retured Null falling to link local
\*Oct 14 15:47:37.331: IPv6 DHCP: Returning Link local address FE80::CA9C:1DFF:FE F1:5340
\*Oct 14 15:47:37.331: IPv6 DHCP: detailed packet contents
\*Oct 14 15:47:37.331: src FE80::CA9C:1DFF:FEF1:5340
\*Oct 14 15:47:37.331: dst FE80::3617:EBFF:FEDF:15B5 (GigabitEthernet0/0)
\*Oct 14 15:47:37.331: type ADVERTISE(2), xid 6547418
\*Oct 14 15:47:37.331: option SERVERID(2), len 10
\*Oct 14 15:47:37.331: 00030001C89C1DF15340
\*Oct 14 15:47:37.331: option CLIENTID(1), len 18
\*Oct 14 15:47:37.331: 000400020003000400050006000700080009
\*Oct 14 15:47:37.331: option IA-NA(3), len 40
\*Oct 14 15:47:37.331: IAID 0xDFFBF777, T1 43200, T2 69120
\*Oct 14 15:47:37.331: option IAADDR(5), len 24
\*Oct 14 15:47:37.331: IPv6 address 2001::8C92:627D:C82D:8FB3
\*Oct 14 15:47:37.331: preferred 86400, valid 172800
\*Oct 14 15:47:37.331: IPv6 DHCP: Sending ADVERTISE to FE80::3617:EBFF:FEDF:15B5 on GigabitEthernet0/0
\*Oct 14 15:48:37.331: IPv6 DHCP: Address 2001::8C92:627D:C82D:8FB3 in binding for FE80::3617:EBFF:FEDF:15B5 expired
\*Oct 14 15:48:37.331: IPv6 DHCP: Freeing address 2001::8C92:627D:C82D:8FB3 to internal pool 2001::/64
\*Oct 14 15:48:37.331: IPv6 DHCP: Freeing IA\_NA DFFBF777 from binding for FE80::3617:EBFF:FEDF:15B5
\*Oct 14 15:48:37.331: IPv6 DHCP: Freeing binding for FE80::3617:EBFF:FEDF:15B5 from pool pxe-pool
\*Oct 14 15:48:52.907: IPv6 DHCP: Received SOLICIT from FE80::3617:EBFF:FEDF:15B5 on GigabitEthernet0/0
\*Oct 14 15:48:52.907: IPv6 DHCP: detailed packet contents
\*Oct 14 15:48:52.907: src FE80::3617:EBFF:FEDF:15B5 (GigabitEthernet0/0)
\*Oct 14 15:48:52.907: dst FF02::1:2
\*Oct 14 15:48:52.907: type SOLICIT(1), xid 6612954
\*Oct 14 15:48:52.907: option CLIENTID(1), len 18
\*Oct 14 15:48:52.907: 000400020003000400050006000700080009
\*Oct 14 15:48:52.907: option ELAPSED-TIME(8), len 2
\*Oct 14 15:48:52.907: elapsed-time 0
\*Oct 14 15:48:52.907: option IA-NA(3), len 12
\*Oct 14 15:48:52.907: IAID 0xDFFBF777, T1 4294967295, T2 4294967295
\*Oct 14 15:48:52.907: option ORO(6), len 4
\*Oct 14 15:48:52.907: UNKNOWN,UNKNOWN
\*Oct 14 15:48:52.907: option UNKNOWN(62), len 3
\*Oct 14 15:48:52.907: option UNKNOWN(61), len 2
\*Oct 14 15:48:52.907: option VENDOR-CLASS(16), len 38
\*Oct 14 15:48:52.911: IPv6 DHCP: Option UNKNOWN(62) is not processed
\*Oct 14 15:48:52.911: IPv6 DHCP: Option UNKNOWN(61) is not processed
\*Oct 14 15:48:52.911: IPv6 DHCP: Option VENDOR-CLASS(16) is not processed
\*Oct 14 15:48:52.911: IPv6 DHCP: Using interface pool pxe-pool
\*Oct 14 15:48:52.911: IPv6 DHCP: Creating binding for FE80::3617:EBFF:FEDF:15B5 in pool pxe-pool
\*Oct 14 15:48:52.911: IPv6 DHCP: Binding for IA\_NA DFFBF777 not found
\*Oct 14 15:48:52.911: IPv6 DHCP: Allocating IA\_NA DFFBF777 in binding for FE80::3617:EBFF:FEDF:15B5
\*Oct 14 15:48:52.911: IPv6 DHCP: Looking up pool 2001::/64 entry with username '000400020003000400050006000700080009DFFBF777'
\*Oct 14 15:48:52.911: IPv6 DHCP: Poolentry for user not found
\*Oct 14 15:48:52.911: IPv6 DHCP: Allocated new address 2001::9170:8423:C856:D33
\*Oct 14 15:48:52.911: IPv6 DHCP: Allocating address 2001::9170:8423:C856:D33 in binding for FE80::3617:EBFF:FEDF:15B5, IAID DFFBF777
\*Oct 14 15:48:52.911: IPv6 DHCP: Updating binding address entry for address 2001::9170:8423:C856:D33
\*Oct 14 15:48:52.911: IPv6 DHCP: Setting timer on 2001::9170:8423:C856:D33 for 60 seconds
\*Oct 14 15:48:52.911: IPv6 DHCP: SAS retured Null falling to link local
\*Oct 14 15:48:52.911: IPv6 DHCP: Returning Link local address FE80::CA9C:1DFF:FEF1:5340
\*Oct 14 15:48:52.911: IPv6 DHCP: detailed packet contents
\*Oct 14 15:48:52.911: src FE80::CA9C:1DFF:FEF1:5340
\*Oct 14 15:48:52.911: dst FE80::3617:EBFF:FEDF:15B5 (GigabitEthernet0/0)
\*Oct 14 15:48:52.911: type ADVERTISE(2), xid 6612954
\*Oct 14 15:48:52.911: option SERVERID(2), len 10
\*Oct 14 15:48:52.911: 00030001C89C1DF15340
\*Oct 14 15:48:52.911: option CLIENTID(1), len 18
\*Oct 14 15:48:52.911: 000400020003000400050006000700080009
\*Oct 14 15:48:52.911: option IA-NA(3), len 40
\*Oct 14 15:48:52.911: IAID 0xDFFBF777, T1 43200, T2 69120
\*Oct 14 15:48:52.911: option IAADDR(5), len 24
\*Oct 14 15:48:52.911: IPv6 address 2001::9170:8423:C856:D33
\*Oct 14 15:48:52.911: preferred 86400, valid 172800
\*Oct 14 15:48:52.911: IPv6 DHCP: Sending ADVERTISE to FE80::3617:EBFF:FEDF:15B5 on GigabitEthernet0/0
\*Oct 14 15:49:52.911: IPv6 DHCP: Address 2001::9170:8423:C856:D33 in binding for FE80::3617:EBFF:FEDF:15B5 expired
\*Oct 14 15:49:52.911: IPv6 DHCP: Freeing address 2001::9170:8423:C856:D33 to internal pool 2001::/64
\*Oct 14 15:49:52.911: IPv6 DHCP: Freeing IA\_NA DFFBF777 from binding for FE80::3617:EBFF:FEDF:15B5
\*Oct 14 15:49:52.911: IPv6 DHCP: Freeing binding for FE80::3617:EBFF:FEDF:15B5 from pool pxe-pool
PXE-Robert#conf t
Enter configuration commands, one per line. End with CNTL/Z.
PXE-Robert(config)#ipv6 dhcp pool pxe-pool
PXE-Robert(config-dhcpv6)#vendor-specific 61
PXE-Robert(config-dhcpv6-vs)#su
PXE-Robert(config-dhcpv6-vs)#suboption 1 ?
address IPv6 address
ascii ASCII string
hex Hex value
PXE-Robert(config-dhcpv6-vs)#suboption 1 address 2001::1
PXE-Robert(config-dhcpv6-vs)#vendor-specific 62
PXE-Robert(config-dhcpv6-vs)#suboption 1 address 2001::1
PXE-Robert(config-dhcpv6-vs)#do show run | beg pool
ipv6 dhcp pool pxe-pool
address prefix 2001::/64
domain-name cnap.hv.se
vendor-specific 61
suboption 1 address 2001::1
vendor-specific 62
suboption 1 address 2001::1
vendor-specific 66
suboption 1 address 2001::1
vendor-specific 67
suboption 1 ascii "ipxe.efi"
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
license udi pid CISCO2921/K9 sn FTX1510AKBZ
!
!
PXE-Robert(config-dhcpv6-vs)#
PXE-Robert(config-dhcpv6-vs)#
PXE-Robert(config-dhcpv6-vs)#
# debug v6
*Oct 14 15:56:03.507: IPv6 DHCP: Received SOLICIT from FE80::3617:EBFF:FEDF:15B5 on GigabitEthernet0/0
*Oct 14 15:56:03.507: IPv6 DHCP: detailed packet contents
*Oct 14 15:56:03.507: src FE80::3617:EBFF:FEDF:15B5 (GigabitEthernet0/0)
*Oct 14 15:56:03.507: dst FF02::1:2
*Oct 14 15:56:03.507: type SOLICIT(1), xid 6678490
*Oct 14 15:56:03.507: option CLIENTID(1), len 18
*Oct 14 15:56:03.507: 000400020003000400050006000700080009
*Oct 14 15:56:03.507: option ELAPSED-TIME(8), len 2
*Oct 14 15:56:03.507: elapsed-time 0
*Oct 14 15:56:03.507: option IA-NA(3), len 12
*Oct 14 15:56:03.507: IAID 0xDFFBF777, T1 4294967295, T2 4294967295
*Oct 14 15:56:03.507: option ORO(6), len 4
*Oct 14 15:56:03.507: UNKNOWN,UNKNOWN
*Oct 14 15:56:03.507: option UNKNOWN(62), len 3
*Oct 14 15:56:03.507: option UNKNOWN(61), len 2
*Oct 14 15:56:03.507: option VENDOR-CLASS(16), len 38
*Oct 14 15:56:03.511: IPv6 DHCP: Option UNKNOWN(62) is not processed
*Oct 14 15:56:03.511: IPv6 DHCP: Option UNKNOWN(61) is not processed
*Oct 14 15:56:03.511: IPv6 DHCP: Option VENDOR-CLASS(16) is not processed
*Oct 14 15:56:03.511: IPv6 DHCP: Using interface pool pxe-pool
*Oct 14 15:56:03.511: IPv6 DHCP: Creating binding for FE80::3617:EBFF:FEDF:15B5 in pool pxe-pool
*Oct 14 15:56:03.511: IPv6 DHCP: Binding for IA_NA DFFBF777 not found
*Oct 14 15:56:03.511: IPv6 DHCP: Allocating IA_NA DFFBF777 in binding for FE80::3617:EBFF:FEDF:15B5
*Oct 14 15:56:03.511: IPv6 DHCP: Looking up pool 2001::/64 entry with username '000400020003000400050006000700080009DFFBF777'
*Oct 14 15:56:03.511: IPv6 DHCP: Poolentry for user not found
*Oct 14 15:56:03.511: IPv6 DHCP: Allocated new address 2001::8C3D:F8CE:1A3B:9F5C
*Oct 14 15:56:03.511: IPv6 DHCP: Allocating address 2001::8C3D:F8CE:1A3B:9F5C in binding for FE80::3617:EBFF:FEDF:15B5, IAID DFFBF777
*Oct 14 15:56:03.511: IPv6 DHCP: Updating binding address entry for address 2001::8C3D:F8CE:1A3B:9F5C
*Oct 14 15:56:03.511: IPv6 DHCP: Setting timer on 2001::8C3D:F8CE:1A3B:9F5C for 60 seconds
*Oct 14 15:56:03.511: IPv6 DHCP: SAS retured Null falling to link local
*Oct 14 15:56:03.511: IPv6 DHCP: Returning Link local address FE80::CA9C:1DFF:FEF1:5340
*Oct 14 15:56:03.511: IPv6 DHCP: detailed packet contents
*Oct 14 15:56:03.511: src FE80::CA9C:1DFF:FEF1:5340
*Oct 14 15:56:03.511: dst FE80::3617:EBFF:FEDF:15B5 (GigabitEthernet0/0)
*Oct 14 15:56:03.511: type ADVERTISE(2), xid 6678490
*Oct 14 15:56:03.511: option SERVERID(2), len 10
*Oct 14 15:56:03.511: 00030001C89C1DF15340
*Oct 14 15:56:03.511: option CLIENTID(1), len 18
*Oct 14 15:56:03.511: 000400020003000400050006000700080009
*Oct 14 15:56:03.511: option IA-NA(3), len 40
*Oct 14 15:56:03.511: IAID 0xDFFBF777, T1 43200, T2 69120
*Oct 14 15:56:03.511: option IAADDR(5), len 24
*Oct 14 15:56:03.511: IPv6 address 2001::8C3D:F8CE:1A3B:9F5C
*Oct 14 15:56:03.511: preferred 86400, valid 172800
*Oct 14 15:56:03.511: IPv6 DHCP: Sending ADVERTISE to FE80::3617:EBFF:FEDF:15B5 on GigabitEthernet0/0
*Oct 14 15:56:41.427: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to down
*Oct 14 15:56:42.427: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to down
*Oct 14 15:56:42.427: IPv6 DHCP: Delete routes, pool pxe-pool, idb GigabitEthernet0/0
*Oct 14 15:56:51.427: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to up
*Oct 14 15:56:52.427: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
*Oct 14 15:56:53.427: IPv6 DHCP: Add routes, pool pxe-pool, idb GigabitEthernet0/0
*Oct 14 15:57:03.511: IPv6 DHCP: Address 2001::8C3D:F8CE:1A3B:9F5C in binding for FE80::3617:EBFF:FEDF:15B5 expired
*Oct 14 15:57:03.511: IPv6 DHCP: Freeing address 2001::8C3D:F8CE:1A3B:9F5C to internal pool 2001::/64
*Oct 14 15:57:03.511: IPv6 DHCP: Freeing IA_NA DFFBF777 from binding for FE80::3617:EBFF:FEDF:15B5
*Oct 14 15:57:03.511: IPv6 DHCP: Freeing binding for FE80::3617:EBFF:FEDF:15B5 from pool pxe-pool
*Oct 14 15:57:11.427: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to down
*Oct 14 15:57:12.427: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to down
*Oct 14 15:57:12.427: IPv6 DHCP: Delete routes, pool pxe-pool, idb GigabitEthernet0/0
PXE-Robert(config-dhcpv6-vs)#exit
PXE-Robert(config-dhcpv6)#exit
# Lets try IPv4
### Config from IP phone CME router
enable
configure terminal
ip dhcp pool pool-name
network ip-address [ mask | / prefix-length ]
option 150 ip ip-address
default-router ip-address
end
```cisco
PXE-Robert(config)#interf gi 0/2
PXE-Robert(config-if)#ip address 10.0.0.1 255.255.255.0 ?
secondary Make this IP address a secondary address
cr>
PXE-Robert(config-if)#ip address 10.0.0.1 255.255.255.0
PXE-Robert(config-if)#no shut
PXE-Robert(config-if)#
\*Oct 14 15:57:41.991: %LINK-3-UPDOWN: Interface GigabitEthernet0/2, changed state to down
PXE-Robert(config-if)#
\*Oct 14 15:57:46.435: %LINK-3-UPDOWN: Interface GigabitEthernet0/2, changed state to up
\*Oct 14 15:57:47.435: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/2, changed state to up
PXE-Robert(config-if)#exit
PXE-Robert(config)#ip dhxcp pool v4-pool
^
% Invalid input detected at '^' marker.
PXE-Robert(config)#ip dhcp pool v4-pool
PXE-Robert(dhcp-config)#netw
PXE-Robert(dhcp-config)#network 10.0.0.0 ?
/nn or A.B.C.D Network mask or prefix length
cr>
PXE-Robert(dhcp-config)#network 10.0.0.0/24
^
% Invalid input detected at '^' marker.
PXE-Robert(dhcp-config)#network 10.0.0.0 /24
PXE-Robert(dhcp-config)#defa
PXE-Robert(dhcp-config)#default-router 10.0.0.1
PXE-Robert(dhcp-config)#
\*Oct 14 15:59:10.427: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/2, changed state to down
\*Oct 14 15:59:11.427: %LINK-3-UPDOWN: Interface GigabitEthernet0/2, changed state to down
PXE-Robert(dhcp-config)#interf gi 0/
\*Oct 14 15:59:15.427: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to up
\*Oct 14 15:59:16.427: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed
\*Oct 14 15:59:17.427: IPv6 DHCP: Add routes, pool pxe-pool, idb GigabitEthernet0/0
PXE-Robert(dhcp-config)#show running | beg pool
^
% Invalid input detected at '^' marker.
IPv4 PXE config PXE-Robert(dhcp-config)#do show running | beg pool ip dhcp pool v4-pool network 10.0.0.0 255.255.255.0 default-router 10.0.0.1 ! ! ! ip cef ipv6 dhcp pool pxe-pool address prefix 2001::/64 domain-name cnap.hv.se vendor-specific 61 suboption 1 address 2001::1 vendor-specific 62 suboption 1 address 2001::1 vendor-specific 66 suboption 1 address 2001::1 vendor-specific 67 suboption 1 ascii "ipxe.efi" ! no ipv6 cef ! multilink bundle-name authenticated !
PXE-Robert(dhcp-config)#pv6 dhcp pool pxe-pool
^
% Invalid input detected at '^' marker.
PXE-Robert(dhcp-config)#ipv6 dhcp pool pxe-pool
PXE-Robert(config-dhcpv6)#?
IPv6 DHCP configuration commands:
address IPv6 address allocation
default Set a command to its defaults
dns-server DNS servers
domain-name Domain name to complete unqualified host names
exit Exit from DHCPv6 configuration mode
import Import options
information Information refresh option
link-address Link-address to match
nis NIS server options
nisp NISP server options
no Negate a command or set its defaults
option DHCPv6 Options configuration
prefix-delegation IPv6 prefix delegation
sip SIP server options
sntp SNTP server options
vendor-specific Configure Vendor-specific option
vrf Associate pool with a VRF
PXE-Robert(config-dhcpv6)#dns
PXE-Robert(config-dhcpv6)#dns-server 2001::1
PXE-Robert(config-dhcpv6)#opt
PXE-Robert(config-dhcpv6)#option ?
include-all Include all DHCPv6 configured options in REPLY
PXE-Robert(config-dhcpv6)#option incl
PXE-Robert(config-dhcpv6)#option include-all
PXE-Robert(config-dhcpv6)#exit
PXE-Robert(config)#do show run | beg v4-poo
ip dhcp pool v4-pool
network 10.0.0.0 255.255.255.0
default-router 10.0.0.1
!
!
!
ip cef
ipv6 dhcp pool pxe-pool
address prefix 2001::/64
dns-server 2001::1
domain-name [cnap.hv.se](http://cnap.hv.se)
vendor-specific 61
suboption 1 address 2001::1
vendor-specific 62
suboption 1 address 2001::1
vendor-specific 66
suboption 1 address 2001::1
vendor-specific 67
suboption 1 ascii "ipxe.efi"
option include-all
!
no ipv6 cef
!
\# reslutat IPv4 LOGGING PXE-Robert(config)#ip dhcp pool v4-pool PXE-Robert(dhcp-config)#lea PXE-Robert(dhcp-config)#lease info PXE-Robert(dhcp-config)#lease inf PXE-Robert(dhcp-config)#lease infinite PXE-Robert(dhcp-config)# PXE-Robert(dhcp-config)# \*Oct 14 16:01:34.427: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to down \*Oct 14 16:01:35.427: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to down \*Oct 14 16:01:35.427: IPv6 DHCP: Delete routes, pool pxe-pool, idb GigabitEthernet0/0 \*Oct 14 16:01:49.427: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to up \*Oct 14 16:01:50.427: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up \*Oct 14 16:01:51.427: IPv6 DHCP: Add routes, pool pxe-pool, idb GigabitEthernet0/0 PXE-Robert# PXE-Robert#d \*Oct 14 16:02:15.935: %SYS-5-CONFIG\_I: Configured from console by consoleebug dhcp ? detail DHCP packet content redundancy DHCP client redundancy support
PXE-Robert#debug dhcp deta
PXE-Robert#debug dhcp detail
DHCP client activity debugging is on (detailed)
PXE-Robert#
\*Oct 14 16:02:30.467: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:02:35.467: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:02:38.427: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to down
\*Oct 14 16:02:39.427: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to down
\*Oct 14 16:02:39.427: IPv6 DHCP: Delete routes, pool pxe-pool, idb GigabitEthernet0/0
\*Oct 14 16:02:40.467: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:02:45.555: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:02:47.427: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to up
\*Oct 14 16:02:48.427: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to up
\*Oct 14 16:02:49.427: IPv6 DHCP: Add routes, pool pxe-pool, idb GigabitEthernet0/0
\*Oct 14 16:02:50.555: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:02:55.427: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/0, changed state to down
\*Oct 14 16:02:55.555: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:02:56.435: %LINK-3-UPDOWN: Interface GigabitEthernet0/0, changed state to down
PXE-Robert#
\*Oct 14 16:02:56.435: IPv6 DHCP: Delete routes, pool pxe-pool, idb GigabitEthernet0/0conf t
Enter configuration commands, one per line. End with CNTL/Z.
PXE-Robert(config)#
\*Oct 14 16:02:59.427: %LINK-3-UPDOWN: Interface GigabitEthernet0/2, changed state to up
\*Oct 14 16:03:00.427: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/2, changed state to upinterf gi
\*Oct 14 16:03:00.555: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up 0/2
PXE-Robert(config-if)#no shut
PXE-Robert(config-if)#^Z
PXE-Robert#
\*Oct 14 16:03:05.555: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
PXE-Robert#wr
Building configuration...
\*Oct 14 16:03:07.263: %SYS-5-CONFIG\_I: Configured from console by console\[OK\]
PXE-Robert#
\*Oct 14 16:03:10.595: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:03:15.595: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:03:20.595: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:03:25.595: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:03:30.595: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
PXE-Robert#
\*Oct 14 16:03:35.595: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come updebug ip dh
PXE-Robert#debug ip dhcp
\*Oct 14 16:03:40.595: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up?
server DHCP server activity
snooping DHCP Snooping
PXE-Robert#debug ip dhcp ser
PXE-Robert#debug ip dhcp server ?
class Class-based address allocation
events Report address assignments, lease expirations, etc.
linkage Show database linkage
packet Decode message receptions and transmissions
redundancy DHCP server redundancy events
PXE-Robert#debug ip dhcp server
\*Oct 14 16:03:45.643: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come uppacket
DHCP server packet debugging is on.
PXE-Robert#
\*Oct 14 16:03:50.643: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come updebug ip dhcp server eve
PXE-Robert#debug ip dhcp server events
\*Oct 14 16:03:55.643: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
DHCP server event debugging is on.
PXE-Robert#
PXE-Robert#
PXE-Robert#
\*Oct 14 16:04:00.643: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
PXE-Robert#
\*Oct 14 16:04:05.643: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:04:10.643: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:04:15.643: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:04:15.811: DHCPD: checking for expired leases.
PXE-Robert#
\*Oct 14 16:04:20.643: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:04:25.643: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:04:28.427: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/2, changed state to down
\*Oct 14 16:04:29.427: %LINK-3-UPDOWN: Interface GigabitEthernet0/2, changed state to down
\*Oct 14 16:04:30.643: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:04:35.643: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:04:35.863: DHCPD: New packet workspace 0x22207528 (ID=0x6E000002)
\*Oct 14 16:04:35.863: DHCPD: client's VPN is .
\*Oct 14 16:04:35.863: DHCPD: No option 125
\*Oct 14 16:04:35.863: DHCPD: Option 125 not present in the msg.
\*Oct 14 16:04:35.863: DHCPD: Sending notification of DISCOVER:
\*Oct 14 16:04:35.863: DHCPD: htype 1 chaddr 3417.ebdf.15b5
\*Oct 14 16:04:35.863: DHCPD: remote id 020a00000a00000102000000
\*Oct 14 16:04:35.863: DHCPD: circuit id 00000000
\*Oct 14 16:04:35.863: DHCPD: DHCPDISCOVER received from client 3417.ebdf.15b5 on interface GigabitEthernet0/2.
\*Oct 14 16:04:35.863: DHCPD: Option 125 not present in the msg.
\*Oct 14 16:04:35.863: DHCPD: Seeing if there is an internally specified pool class:
\*Oct 14 16:04:35.863: DHCPD: htype 1 chaddr 3417.ebdf.15b5
\*Oct 14 16:04:35.863: DHCPD: remote id 020a00000a00000102000000
\*Oct 14 16:04:35.863: DHCPD: circuit id 00000000
\*Oct 14 16:04:35.863: DHCPD: Found previous server binding
\*Oct 14 16:04:35.863: DHCPD: Sending DHCPOFFER to client 3417.ebdf.15b5 (10.0.0.2).DHCPD: Setting only requested parameters
\*Oct 14 16:04:35.863: DHCPD: Option 125 not present in the msg.
\*Oct 14 16:04:35.863: DHCPD: no option 125
\*Oct 14 16:04:35.863: DHCPD: broadcasting BOOTREPLY to client 3417.ebdf.15b5.
\*Oct 14 16:04:37.427: %LINK-3-UPDOWN: Interface GigabitEthernet0/2, changed state to up
\*Oct 14 16:04:38.427: %LINEPROTO-5-UPDOWN: Line protocol on Interface GigabitEthernet0/2, changed state to up
\*Oct 14 16:04:38.991: DHCPD: client's VPN is .
\*Oct 14 16:04:38.991: DHCPD: No option 125
\*Oct 14 16:04:38.991: DHCPD: Option 125 not present in the msg.
\*Oct 14 16:04:38.991: DHCPD: Sending notification of DISCOVER:
\*Oct 14 16:04:38.991: DHCPD: htype 1 chaddr 3417.ebdf.15b5
\*Oct 14 16:04:38.991: DHCPD: remote id 020a00000a00000102000000
\*Oct 14 16:04:38.991: DHCPD: circuit id 00000000
\*Oct 14 16:04:38.991: DHCPD: DHCPDISCOVER received from client 3417.ebdf.15b5 on interface GigabitEthernet0/2.
\*Oct 14 16:04:38.991: DHCPD: Option 125 not present in the msg.
\*Oct 14 16:04:38.991: DHCPD: Seeing if there is an internally specified pool class:
\*Oct 14 16:04:38.991: DHCPD: htype 1 chaddr 3417.ebdf.15b5
\*Oct 14 16:04:38.991: DHCPD: remote id 020a00000a00000102000000
\*Oct 14 16:04:38.991: DHCPD: circuit id 00000000
\*Oct 14 16:04:38.991: DHCPD: Found previous server binding
\*Oct 14 16:04:38.991: DHCPD: Sending DHCPOFFER to client 3417.ebdf.15b5 (10.0.0.2).DHCPD: Setting only requested parameters
\*Oct 14 16:04:38.991: DHCPD: Option 125 not present in the msg.
\*Oct 14 16:04:38.991: DHCPD: no option 125
\*Oct 14 16:04:38.991: DHCPD: broadcasting BOOTREPLY to client 3417.ebdf.15b5.
\*Oct 14 16:04:40.643: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:04:45.731: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:04:46.955: DHCPD: client's VPN is .
\*Oct 14 16:04:46.955: DHCPD: No option 125
\*Oct 14 16:04:46.955: DHCPD: Option 125 not present in the msg.
\*Oct 14 16:04:46.955: DHCPD: Sending notification of DISCOVER:
\*Oct 14 16:04:46.955: DHCPD: htype 1 chaddr 3417.ebdf.15b5
\*Oct 14 16:04:46.955: DHCPD: remote id 020a00000a00000102000000
\*Oct 14 16:04:46.955: DHCPD: circuit id 00000000
\*Oct 14 16:04:46.955: DHCPD: DHCPDISCOVER received from client 3417.ebdf.15b5 on interface GigabitEthernet0/2.
\*Oct 14 16:04:46.955: DHCPD: Option 125 not present in the msg.
\*Oct 14 16:04:46.955: DHCPD: Seeing if there is an internally specified pool class:
\*Oct 14 16:04:46.955: DHCPD: htype 1 chaddr 3417.ebdf.15b5
\*Oct 14 16:04:46.955: DHCPD: remote id 020a00000a00000102000000
\*Oct 14 16:04:46.955: DHCPD: circuit id 00000000
\*Oct 14 16:04:46.955: DHCPD: Found previous server binding
\*Oct 14 16:04:46.955: DHCPD: Sending DHCPOFFER to client 3417.ebdf.15b5 (10.0.0.2).DHCPD: Setting only requested parameters
\*Oct 14 16:04:46.955: DHCPD: Option 125 not present in the msg.
\*Oct 14 16:04:46.955: DHCPD: no option 125
\*Oct 14 16:04:46.955: DHCPD: broadcasting BOOTREPLY to client 3417.ebdf.15b5.
\*Oct 14 16:04:50.731: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:04:55.731: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:05:00.731: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:05:02.939: DHCPD: client's VPN is .
\*Oct 14 16:05:02.939: DHCPD: No option 125
\*Oct 14 16:05:02.939: DHCPD: Option 125 not present in the msg.
\*Oct 14 16:05:02.939: DHCPD: Sending notification of DISCOVER:
\*Oct 14 16:05:02.939: DHCPD: htype 1 chaddr 3417.ebdf.15b5
\*Oct 14 16:05:02.939: DHCPD: remote id 020a00000a00000102000000
\*Oct 14 16:05:02.939: DHCPD: circuit id 00000000
\*Oct 14 16:05:02.939: DHCPD: DHCPDISCOVER received from client 3417.ebdf.15b5 on interface GigabitEthernet0/2.
\*Oct 14 16:05:02.939: DHCPD: Option 125 not present in the msg.
\*Oct 14 16:05:02.939: DHCPD: Seeing if there is an internally specified pool class:
\*Oct 14 16:05:02.939: DHCPD: htype 1 chaddr 3417.ebdf.15b5
\*Oct 14 16:05:02.939: DHCPD: remote id 020a00000a00000102000000
\*Oct 14 16:05:02.939: DHCPD: circuit id 00000000
\*Oct 14 16:05:02.939: DHCPD: Found previous server binding
\*Oct 14 16:05:02.939: DHCPD: Sending DHCPOFFER to client 3417.ebdf.15b5 (10.0.0.2).DHCPD: Setting only requested parameters
\*Oct 14 16:05:02.939: DHCPD: Option 125 not present in the msg.
\*Oct 14 16:05:02.939: DHCPD: no option 125
\*Oct 14 16:05:02.939: DHCPD: broadcasting BOOTREPLY to client 3417.ebdf.15b5.
\*Oct 14 16:05:05.731: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:05:10.731: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:05:15.731: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:05:20.731: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:05:25.731: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:05:30.731: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:05:35.731: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:05:40.731: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:05:45.819: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:05:50.819: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:05:55.819: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:06:00.819: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:06:05.819: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:06:10.819: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:06:15.811: DHCPD: checking for expired leases.
\*Oct 14 16:06:15.819: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:06:20.819: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
\*Oct 14 16:06:25.819: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come up
PXE-Robert#
PXE-Robert#show runn
\*Oct 14 16:08:35.995: DHCP: Waiting for 5 seconds on interface GigabitEthernet0/1 to come uping
Building configuration...
Current configuration : 1645 bytes
!
! Last configuration change at 16:03:07 UTC Fri Oct 14 2022
!
version 15.7
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname PXE-Robert
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
ip dhcp pool v4-pool
network 10.0.0.0 255.255.255.0
default-router 10.0.0.1
lease infinite
!
!
!
ip cef
ipv6 dhcp pool pxe-pool
address prefix 2001::/64
dns-server 2001::1
domain-name [cnap.hv.se](http://cnap.hv.se)
vendor-specific 61
suboption 1 address 2001::1
vendor-specific 62
suboption 1 address 2001::1
vendor-specific 66
suboption 1 address 2001::1
vendor-specific 67
suboption 1 ascii "ipxe.efi"
option include-all
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
license udi pid CISCO2921/K9 sn FTX1510AKBZ
!
!
!
redundancy
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface Embedded-Service-Engine0/0
no ip address
shutdown
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed auto
ipv6 address 2001::1/64
ipv6 nd other-config-flag
ipv6 dhcp server pxe-pool
!
interface GigabitEthernet0/1
ip address dhcp
shutdown
duplex auto
speed auto
!
interface GigabitEthernet0/2
ip address 10.0.0.1 255.255.255.0
duplex auto
speed auto
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
!
ipv6 ioam timestamp
!
!
!
control-plane
!
!
vstack
!
line con 0
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport output lat pad telnet rlogin lapb-ta mop udptn v120 ssh
stopbits 1
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end
PXE-Robert#
wiki.js: Rending Module > Security > Allow iframes to allow video-iFrames
Keith Barker: Enable and Verify RESTCONF with the CLI and Postman.
hostname name
ip domain-name name.com
crypto key generate rsa usage-keys
! (OBS; måste vara default 512)
!
! ! ONLY WHEN PUBLIC CERTIFICATE, not self-signed. Please IGNORE
! 6. crypto ca trustpoint name
! 7. enrollment url url
! 8. enrollment http-proxy host-name port-number
! 9. crl {query url | optional | best-effort}
! 10. primary
! 11. exit
! 12. crypto ca authenticate name
! 13. crypto ca enrollment name
!
username cisco secret cisco
ip http authentication local
! ip http server !! Kan vara bra för att testa, men behövs inte
ip http secure-server
??? ip http secure-client-auth
??? crypto ssl cipher-list cipher-list-name
?? web-gränssnittet fungerar inte (vit sida) om man är inne i conf t !?!
?? Om du inte har sparat (wr), så hittar inte web-UI confen, utan börjar från början)
Kräver NTP ?? ntp server ntp.hv.se
Make sure that you use https above
IOS-prompt# restconf
(One single command, no parameters )